[Users] Prise en charge des macros Python / OOo4Kids1.3

Marie Brungard contact at arkaline.fr
Mer 26 Sep 17:34:17 CEST 2012


Bonsoir.

Au début de l'été, j'avais eu un souci assez similaire. Eric Bachard 
avait alors suggéré que OOo4Kids avait été compilé avec Python 2.5 et 
pas avec le Python 2.6 ou 2.7. Il avait proposé de créer un lien 
symbolique pour simuler l'existence d'une libpython2.5 et cela avait 
résolu mes problèmes d'alors. Voici la commande pour créer ce lien :

(sudo) ln -s  /usr/lib/libpython2.7.so.1 /usr/lib/libpython2.5.so.1.0

Avant, il serait peut-être bon de vérifier que la libpython2.5 n'existe 
vraiment pas (ls -l /usr/lib/libpython*  ne doit pas faire apparaître de 
libpython2.5)

Peut-être que cela peut répondre au moins partiellement à la question. 
Mais a priori, le problème ne vient pas des macros mais de la manière 
dont a été compilé OOo4kids, si je ne me trompe pas... Après cela, il 
faut tout de même utiliser la barre d'outils et pas les boutons en haut 
de page.

Cordialement,

Marie-Pierre Brungard

Le 26/09/2012 13:42, Fred Juan DIAZ a écrit :
> Bonjour
>
> je suis en train de tenter de faire tourner les macros de Marie Pierre
> logix_niveau_1.odg
> Sur OOo4Kids1.3 deb fraîchement installé,  et je ramasse le message suivant :
>
> =================================================================
> Une erreur de structure de script s'est produite lors de l'exécution
> du script genexopy.py$open_genexopy_document de Python.
>
> Message : le langage de script Python n'est pas pris en charge
> =================================================================
>
> ma question est la suivante : y a-t-il de manière systématique une config spéciale à faire (chemin, variable...) pour que cela tourne ?
>
> cordialement
>
> FJD
> _______________________________________________
> Users mailing list
> Users at lists.educoo.org
> https://listes.lautre.net/cgi-bin/mailman/listinfo/users
>


Plus d'informations sur la liste de diffusion Users